
1. Introduction 
This case focuses on the northeastern region of Onslow Bay, NC, and includes an initial 
shoreline, regional contour, wave gauges, inlets, dredging, and beach fills. Most of the features 
used in this grid come from the capabilities of Cascade (calculating across inlets). It is more 
complex than the simple example, but it is not as intensive as the Long Island example. This 
model was calibrated as part of a previous study; however, some features such as a groin and 
comprehensive dredging are not included in this example mode. Therefore, this example case has 
not been verified. 
 

 
Figure 1 – Example feature overview. 

 
2. Conceptual Model Setup 
As much of the setup as possible is done in conceptual model space through the SMS map 
module. Creating the model in this manner, rather than making changing in the 1D grid module, 
enables modification without duplication of effort. 
 
2.1 Set Up SMS 11.1 

• Open SMS 11.1 
• Identify location of GenCade executable. 

o Edit->Preferences. Select the File Locations tab and scroll down to GenCade 
under Model Executables. 

o Click the button under Executable located directly to the right of GenCade. 
o Browse to the latest model version, GenCade_v1r1.exe, the newest provided 

executable. 
• Change coverage type to GenCade. 

o Right click on the default coverage. 
o Select Type-> Models->GenCade. 



 
Figure 2. Set Model Type to GenCade. 

 
• Set display projection. 

o Click Edit->Projection then select Global projection. 
o Set projection to State Plane Coordinate System, North Carolina (FIPS 3200), 

NAD83, feet (U.S. Survey). 
o Set vertical projection to local with units in feet. 

• Note: The sign convention for the conceptual model grid is in degrees 
counterclockwise from the x axis. The sign convention will change after converting to 
the GenCade grid. 

• Set map data projection in SMS. 
o Right click on the Coverage name and select Projection (floating). 
o Select Global projection. 
o Set projection to State Plane Coordinate System, North Carolina (FIPS 3200), 

NAD83, feet (U.S. Survey). 
o Set vertical projection to local with units in feet. 

 



 
Figure 3. Set Model Projection. 

 
2.2 Initial Shoreline and Regional Contour 
The initial shoreline represents the initial condition from which model calculations begin. The 
regional contour represents the equilibrium shape of the shoreline in a regional context. A 
regional contour could be specified as an offshore contour, shoreline, or any other contour that 
accurately represents the regional shoreline trends. 

• The initial shoreline in *.cst format is located in \ initial\1997initial.cst. The format of the 
*.cst file was discussed in the simple example, so it will not be repeated here.  

• Click the Select Features Arc  button and click on the arc. The GenCade Arc 
Attributes window will open. Define the arc as Initial Shoreline. 



 
Figure 4. Set Initial Shoreline. 

 
• Right click on Map Data and click on New Coverage. Name the new coverage 

Regional_contour. Scroll down under Coverage Type to GenCade. 
• Open regional_contour.cst in the SMS (located in  \regional_contour). Click on Select 

Feature Arc and select Regional Contour under Arc Options of the GenCade Arc 
Attributes window. 

• Merge the regional contour and the initial shoreline in one coverage. 
o Select the initial shoreline and regional contour coverages; hold down CTRL to 

select multiple coverages. 
o Right click and select Merge Coverages. 

 A window will open providing the option to delete the source coverages. 
Select No to save the old coverages in case you need to merge again. 

 A new coverage is created named Merge coverage. 
 Delete the initial shoreline and regional contour coverages if no longer 

needed. 
 

2.3 Import Aerial Photograph 
Georeferenced aerials provide an easy way of identifying features to include in GenCade, 
forming the basis for much of the model setup. Take the following steps to import the aerial: 



• Open \ aerial\N-18-30_2000.sid. 
• Right click on the aerial and go to Projection. Notice that the projection of the aerial is in 

UTM, WGS84, Meters, Zone 18. It is not necessary to convert to the same projection as 
the project. If the user converts the projection of the aerial in the SMS, the *.prj will be 
permanently modified. 
 

2.4 Inlets 
Although the shorelines in the merged coverage extend from Cape Lookout to Cape Fear, this 
example only includes the northeastern section of Onslow Bay. This example includes the two 
northernmost inlets, Beaufort Inlet and Bogue Inlet. Beaufort Inlet is located at (2700203, 
351058) while Bogue Inlet is at (2567933, 329182). 

• Create a feature arc from east to west across Beaufort Inlet. The position of the inlet on 
the GenCade grid is controlled by the location of the two endpoints.  

• Once Beaufort Inlet is drawn, select the arc and double-click on the line representing the 
inlet. 

• Select Inlet from the drop down menu and select Attributes. Name the inlet Beaufort. 
• Set the Inlet Shoal Volumes under the Volume button to match the table below. 

 

 
Figure 5. Assign Inlet Attributes. 

 



Table 1. Beaufort Inlet Shoal Volumes 
Beaufort Inlet 

  
 

Initial, yd3 Equilibrium, yd 3 

Ebb 2,920,000 2,920,000 
Flood 2,920,000 2,920,000 

Left Bypass 13,967,000 20,440,000 
Left Attachment 1,460,000 1,460,000 

Right Bypass 23,776,000 100,000,000 
Right Attachment 1,460,000 1,460,000 

 
• Specify two dredging events by clicking on Dredging. 

o Begin Date: 01-Jul-1997; End Date: 01-Sep-1997; Shoal to be Mined: Right 
Bypass; Volume: 187,359 

o Begin Date: 01-Jul-1997; End Date: 01-Sep-1997; Shoal to be Mined: Left 
Bypass; Volume: 80,297 

 

 
Figure 6.Assign Dredging Attributes. 

 
• Change Right Bypass Coef to 3. 



• Click Ok to exit Attributes. The feature arc will turn blue representing an inlet. 
• Add a right jetty by creating a new feature arc. The coordinates of the ends of the jetty 

are (2698300, 352008) and (2698445, 351294). 
• Click on the arc to open the GenCade Arc Attributes window. Define the arc as Right 

Jetty on Inlet* and go to Attributes. Change the Permeability to 0.5, check Diffracting, 
and define the Seaward Depth as 5 ft.  
 
* The jetty to the west is considered the “right” jetty based on GenCade configuration. 
Consider a person on a vessel in the middle of the inlet looking out into the ocean. The 
left jetty is always to the left of the person based on the direction the person is facing. For 
this case, the left jetty is the east jetty and the right jetty is the west jetty.   
 

• Create a feature arc representing Bogue Inlet. Select the arc, and double-click on the line 
representing the inlet. 

• Select Inlet from the drop down menu and select Attributes. Name the inlet Bogue. 
• Set the Inlet Shoal Volumes under the Volume button to match the table below. 
 

Table 2. Bogue Inlet Shoal Volumes. 
Bogue Inlet     

  Initial, yd3 Equilibrium, yd3 

Ebb 15,300,000 15,300,000 
Flood 15,300,000 15,300,000 

Left Bypass 425,000 425,000 
Left Attachment 425,000 425,000 

Right Bypass 425,000 425,000 
Right Attachment 425,000 425,000 

 
• Bogue Inlet does not have any dredging events or jetties, so no additional information is 

needed for GenCade. 
• Click OK to exit Attributes. The feature arc will turn blue representing an inlet. 

 
2.5 Beach Fills 
There are seven beach fill events on Bogue Banks. Some of these events occur during the same 
time period, but since the quantity of sand is not the same at all locations, it is necessary to 
consider these as two separate beach fill events. 

• Click on the Create Feature Arc button and draw arcs representing beach fills.  
• Click on the Select Feature Arc button and double-click on the arc to open the GenCade 

Arc Attributes window. 
• Define the arc as Beach Fill Event and click on Attributes. 
• Specify the Begin Date, End Date, and Added Berm Width based on the information 

below. 
• After all of the information is entered, the beach fill will turn green. 
• The figure below shows the locations of all of the beach fills. These should be drawn as 

shown and then refined based on the X-Y locations of the nodes. 



 

 
Figure 7. Locations of Beach Fills. 

 

 
Figure 8. Assign Beach Fill Attributes. 

 



 
Table 3. Beach Fill Attributes. 

Number X1 Y1 X2 Y2 
Begin 
Date End Date 

Added 
Berm Width 

1 2,698,160 349,730 2,691,000 349,660 1-Nov-04 1-Dec-04 84 
2 2,698,130 350,420 2,690,975 350,451 1-Jul-02 1-Aug-02 37 
3 2,690,975 350,451 2,666,592 350,501 1-Nov-04 1-Dec-04 84 
4 2,666,592 350,501 2,632,650 345,300 1-Jul-02 1-Aug-02 40 
5 2,666,870 348,780 2,620,040 341,070 8-Feb-04 23-Mar-04 39 
6 2,632,650 345,300 2,620,210 343,456 1-Jul-02 1-Aug-02 57 
7 2,620,210 343,456 2,600,070 338,410 1-Jul-03 1-Sep-03 51 

 
2.6 Wave Gauges 
This example has three WIS wave gauges. 

• Click Edit->Single Point Projection to add a feature point at the coordinates of the wave 
gauge.  

o Under Convert From select Global Projection and Set Projection to Geographic 
with NAD83 as the horizontal datum and Arc Degrees as the Planar Units. Set 
the Vertical Projection to Local and the Units to feet. 

o Under Convert To select Global Projection and Set Projection to State Plane 
Coordinate System, North Carolina (FIPS 3200), with NAD83 as the horizontal 
datum and feet as the Planar Units. Set the Vertical Projection to Local and the 
Units to feet. 

o Longitude: -76.67 
o Latitude: 34.5 
o Check the Create feature point box. 
o Select Close. 

• Double click on the feature point with the Select Feature Point tool and check the Wave 
gage box. Click on the Options button. 

• Enter Depth of 62 ft and click the Data button. 
• Change the Convention to Meteorologic under Interpret Directions As. 
• Click Import and open the desired file for the waves. 
• The five columns should be defined as Date, Time, Height, Period, and Direction. 
• Click Finish. 

 



 
Figure 9. Assign Wave Gauge Attributes. 

 
Repeat the same instructions for the other two wave gauges. 

• Wave Gauge 2: 
o Longitude: -76.83 
o Latitude: 34.5 
o Depth: 69 ft 

• Wave Gauge 3: 
o Longitude: -77.08 
o Latitude: 34.5 
o Depth: 56 ft 

 
2.7 Grid Frame 

• Click the Create 1D Grid Frame button. Click on the location you want the grid frame to 
start and then double-click at the ending location 

o If a person was walking down the grid to the arrow, the water would be to the left 
and the land would be to the right. For example, if the GenCade grid arrow was 
pointing south, the water would be to the east (left) and the land would be to the 
west (right). 



o In this example, the grid frame should start to the northeast of the initial shoreline 
and end to the northwest. The initial shoreline will be located to the south of the 
grid frame. 

It is necessary to convert to a 1D grid before attempting to import wave data in shore normal 
convention. If the wave data are in meteorological, oceanographic, or Cartesian, the wave 
information can be imported prior to setting up the grid frame and converting to the GenCade 
model. The data were in meteorological convention in this example, so all of the steps related to 
the wave gauges were completed before setting up the grid frame. 

• Click on the Select 1D Grid Frame button and then click inside the rectangle that appears 
in the center of the grid frame. 

o The grid frame can be lengthen or shortened by dragging the end point and rotated 
by dragging the circle at the end of the frame. 

• Right click and select Properties, or double-click the rectangle. The Grid Frame 
Properties window will open and the following can be defined: 

o Origin X: 2727719.0798 
o Origin Y: 366426.87964 
o Angle: 190 
o I Size: 181,200 
o Click on Define cell sizes and change the Cell Size to 300 ft. The Number of Cells 

should automatically change to 604. 
 

 
Figure 10.Set Up 1-D Grid Frame. 



3. Convert to GenCade Model Grid 
• Right click on the GenCade coverage and select Convert->Map->1D Grid. 
• Verify the settings in the properties window haven’t changed and select OK. 
• In GenCade, the default setting for the attachment bars is directly adjacent to the inlet. 

For Beaufort Inlet, these locations need to be modified. 
o Select the GenCade grid in the Project Explorer. This will add the GenCade 

menu. 
o Go to GenCade->Edit Inlets. This opens the Inlets(Reservoir Model and Jetties) 

window. 
o Click the Position under Cell for Beaufort Inlet. This opens the Inlet Position 

window. 
o Change the parameters to the following: 

 Left Bypass Beg Cell: 94 
 Left Bypass End Cell: 95 
 Right Bypass Beg Cell: 106 
 Right Bypass End Cell: 107 

• Verify that all information entered in the conceptual model is correct in the GenCade 
model. 

o Select the GenCade grid in the Project Explorer. 
o Under the GenCade menu, all of the inputs can be reviewed or modified. 
o Select GenCade->Edit Grid and notice that the Azimuth is not the same as the 

angle selected in the conceptual grid frame. 
o Note: The sign convention for the GenCade model grid is in degrees clockwise 

from north. Wave data must be relative to the orientation of the GenCade model 
grid and not the conceptual model grid. 

 
4. Setup and Run the GenCade Model 

• Select the GenCade grid in the Project Explorer 
• Go to GenCade->Model Control to open the GenCade Model Control window. 
• Under the Model Setup tab enter the following: 

o Start Date: 01-Jan-1997 12:00 AM 
o End Date: 27-Aug-2004 12:00 AM 
o Time Step: 1 hr 
o Recording Time Step: 168 hr 

• Under the Beach Setup tab enter the following: 
o Effective Grain Size: 0.17 mm 
o Average Berm Height: 4.5 ft 
o Closure Depth: 26.5 ft 
o K1: 0.6 
o K2: 0.4 

• Under the Seaward BC enter the following: 
o Number of Cells in the Offshore Contour Smoothing Window: 100 

• Under Lateral BC enter the following: 
o Left Lateral BC and Right Lateral BC: Pinned 



 
Figure 11. GenCade Model Control. 

 
• Save GenCade by going to File->Save As. 
• Go to GenCade->Run GenCade to run GenCade. 

 
Information about viewing results in the SMS was already discussed in the simple example case, 
so it will not be included here. 
 
  



Supplemental Data for Model Setup 
 
GenCade model setup parameters. 
Parameter Value 
Start Date 1/1/1997 0:00 
End Date 8/27/2004 0:00 
Time Step 1 
Recording Time Step 168 
Effective Grain Size, mm 0.17 
Average Berm Height, ft 4.5 
Depth of Closure, ft 26.5 
K1 0.6 
K2 0.4 
Height Amplification Factor 1 
Angle Amplification Factor 1 
Angle Offset 0 
Wave Components to Apply Primary 
Number of cells in offshore contour smoothing window 100 
Left Lateral Boundary Condition Pinned 
Right Later Boundary Condition, ft per sim. period Pinned 
 
 
Conceptual grid frame parameters. 
Parameter Value 
Origin X, ft 2.727,719.0798 
Origin Y, ft 366,426.87964 
Angle, º 190 
I size, ft 181,200 
Cell Size, ft 300 
Number of Cells 604 
Use Refine Points no 
 
Wave Gauge Locations 

Cell Index Depth, ft 
99 62 

297 69 
547 56 

 
Beaufort Inlet 
  Beginning Cell Ending Cell 
Inlet 96 105 
Left Bypass 94 95 



Right Bypass 106 107 
Beaufort Inlet 
  Initial Equilibrium 
Ebb 2,920,000 2,920,000 
Flood 2,920,000 2,920,000 
Left Bypass 13,967,000 20,440,000 
Left Attachment 1,460,000 1,460,000 
Right Bypass 23,776,000 100,000,000 
Right Attachment 1,460,000 1,460,000 
 
Beaufort Inlet  

Jetty Exists Length Permeability Diffracting Seaward Depth, ft 
Left No - - - - 

Right Yes 9819.59 0.5 Yes 5 
 
Dredging Events 

Begin Date End Date Shoal to be Mined Volume, cu yd 
1-Jul-1997 1-Sep-1997 Right Bypass 187,359 
1-Jul-1997 1-Sep-1997 Left Bypass 80,297 

 
 
Beaufort Inlet 
Left Bypass Coef Right Bypass Coef 

no 3 
 
Bogue Inlet 
  Beginning Cell Ending Cell 
Inlet 531 557 
Left Bypass 530 530 
Right Bypass 558 558 
 
Bogue Inlet 
  Initial Equilibrium 
Ebb 15,300,000 15,300,000 
Flood 15,300,000 15,300,000 
Left Bypass 425,000 425,000 
Left Attachment 425,000 425,000 
Right Bypass 425,000 425,000 
Right Attachment 425,000 425,000 
 



Beach fill parameters. 
Begin Date End Date Start Cell End Cell Added Berm Width, ft 
1-Jul-2002 1-Aug-2002 107 130 37 
1-Nov-2002 1-Dec-2004 107 131 84 
1-Nov-2002 1-Dec-2004 130 210 84 
1-Jul-2002 1-Aug-2002 210 325 40 
8-Feb-2004 23-Mar-2004 210 369 39 
1-Jul-2002 1-Aug-2002 325 367 57 
1-Jul-2003 1-Sep-2003 367 436 51 

 


