1. Introduction
This exercise describes the steps necessary to set up and run a very simple GenCade case and view the results in the SMS 11.1. The set up includes a straight shoreline, one groin, and a wave gauge with idealized waves. Once this case is completed, three additional scenarios will be compared. The final case is identical to the initial scenario, but variable grid resolution is utilized. 
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Figure 1. Simple Example Overview.

Goals for the exercise:
1. Set up a simple GenCade case in the conceptual model
2. Execute and visualize results
3. Modify the model

2. Conceptual Model Setup
The majority of the set up for GenCade occurs in the conceptual model. The conceptual model is located in the map module, so all information is entered in real-world coordinates. Any changes made in the conceptual model can easily be converted to the GenCade grid.


2.1 Set Up SMS 11.1
The conceptual and GenCade model interfaces are only available in SMS 11.1. A licensed copy of SMS 11.1 must be installed on the machine before using. The following steps should be followed before starting to create feature arcs in the conceptual model.

· Open SMS 11.1
· Identify the location of the GenCade executable
· Go to Edit->Preferences. Select the File Locations tab. Scroll to GenCade under Model Executables. 
· Click on the button under Executable located directly to the right of GenCade. If the executable has never been used, this button will say BROWSE.
· Browse to the latest model version. Although the executable can be run from any location, it is recommended that the executable be copied to the models folder in SMS 11.1 under Program Files.
· Change the coverage to GenCade.	
· Right click on the default coverage under Map Data.
· Select Type->Models->GenCade.
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Figure 2. Set Model Type to GenCade.

· Set display projection
· Click Edit->Projection.
· Set the Local Projection to U.S. Survey Feet and the Horizontal Projection to U.S. Survey Feet (Please note that this is a very simple example. When using GenCade for an actual project, the Global Projection should be specified.)

[image: ]
Figure 3. Select Projection.

2.2 Initial Shoreline
The initial shoreline represents the initial condition from which model calculations begin. The initial shoreline can be represented as a shapefile or through a coastline file, *.cst. For this example, a pre-existing *.cst will be used.
· Open initial.cst. The file has five lines of information. Line 1 defines the type of file, while line 2 specifies the number of shorelines in the file. Line 3 informs the user that there are 2 points representing the arc. Lines 4 and 5 represent the x- and y-coordinates for both points. 
· Open initial.cst in the SMS either by File->Open or by dragging the file into the Map Viewer. Once opened in SMS, a black line will appear.
· There are two options to define the arc as the initial shoreline. First, click on the Feature Arc Selection [image: ] button. Then click on the arc once and right click. Scroll down to Attributes. The GenCade Arc Attributes window will open. Select Initial Shoreline under Arc Options and then click OK. The GenCade Arc Attributes window will also open after double clicking on the arc.

[image: ]
Figure 4. Arc Options for Initial Shoreline.

2.3 Groin
In addition to showing how to set up the conceptual model and run in the GenCade model, one main reason for this example is to show how different groins and wave directions affect the shoreline change and longshore transport.
· Click on the Create Feature Arc [image: ] button. This groin should be drawn as close to the center of the shoreline/grid as possible. In GenCade, the grid is always set up to the right of the shoreline and structures. For example, if a person was to walk down the grid, the shoreline is to the right. In this case, a person would walk from right to left, so the shoreline is to the south of the grid. This means that the groin should be added south of the shoreline.
· To start drawing the groin, click the mouse once. To end the groin, double click. Be careful not to intersect the existing arc for the shoreline. If this occurs, the arc will be split into two separate arc. To remedy this, delete the arc representing the groin by clicking Select Feature Arc, clicking on the groin, and pushing Delete. Then click on Select Feature Point [image: ], highlight the point, go to Feature Objects in the main menu, and click on Vertices<->Nodes. This will turn the point into a node.
· Click on Select Feature Arc and select the arc representing the groin. Double click on the arc and open the GenCade Arc Attributes window. Under Arc Options, scroll down to Groin and click on Attributes. The Groins window will open. Change the Permeability to 0.3, check Diffracting, and change the Seaward Depth to 5 ft. Click OK twice. The arc representing the groin will turn blue.
· Click on Select Feature Point and click on one point representing the groin. At the top of the screen, change X to -10000 and Y to -300. The other point should be changed to (-10000, -141).
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Figure 5. Assign Groin Attributes.

2.4 Grid Frame
· Click the Create 1-D Grid Frame [image: ] button, click the location where the grid frame should start and double-click the end location. Again, for this case, the grid is located to the north of the shoreline. The starting location is the upper right and the ending location is the upper left. 
· Reminder: If a person was walking down the grid to the arrow, the water would be on the left and the mainland would be to the right. For example, if the GenCade arrow was point south, the water would be to the east (left) and the land would be to the west (right).
· Click on the Select 1-D Grid Frame [image: ] button, then click inside the rectangle that appears at the center of the grid frame. 
· The grid frame can be lengthened or shortened by dragging the end point and rotated by dragging the circle at the end of the frame.
· Right click and select Properties to define the following values:
· Origin X: 0
· Origin Y: 500
· Angle: 180º
· I size: 20,000 ft
· Cell Size: 100 ft
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Figure 6. Set Up 1-D Grid Frame.

2.5 Wave Data – Part 1
Waves provide the forcing for shoreline change. SMS will accept wave data in meteorological, oceanographic, Cartesian, or shore normal convention. Then the convention will automatically be converted to the required shore normal convention for GenCade. However, the conceptual model does not know what shore normal convention is until after the model has been converted to the grid cells. Real wave data often has gaps or errant data. Therefore, wave data must be processed before it can be applied in GenCade. For this example, a sample wave file has been created in shore normal convention. The wave gauge will be set up in this step, but the data will not be added until after the model is converted to the GenCade model grid since the wave information is in shore normal convention.
· Open waves.txt in your favorite text editor. There are five columns that need to be read into GenCade. The first column represents the date. Its format is YYYYMMDD. The second column is time in HHMM. The third column is wave height (always in meters regardless of the projection). Then columns four and five are the period and direction, respectively.
· Go to Edit->Single Point Projection. Keep both the Convert from and Convert to horizontal units as U.S. Survey Feet. Under Enter Coordinates, X should be -10000 and Y should be -1563. Check the Create feature point and hit Close. A new feature point has been created.
· Click on Select Feature Point and double-click on the new point.
· Check Wave Gauge and click OK.

[image: ]
Figure 7. Reproject Single Point for Wave Gauge Location.
2.6 Convert to GenCade Model Grid
Since the conceptual model does not know the location of the grid, it is necessary to convert to the 1D grid before adding the wave gauge. 
· Right click on default coverage and go to Convert->Map to 1D Grid. The Map->1D Grid window will open. Hit OK. This will create the GenCade grid.

[image: ]
Figure 8. Convert to 1-D Grid.

2.7 Wave Data – Part 2
· Double-click on the point representing the wave gauge by selecting the Select Feature Point icon. The Refine Point window will open. Wave Gauge should already be selected, so click on Options. Enter the Depth (ft) as 50 ft and then click on Data. The Wave Events window will open. Under Interpret Directions as, change the Convention to Shore Normal. Next, click on Import… Find the location of waves.txt and click Open. The Import Wizard – Step 1 of 2 will open. Hit Next > and then define the five columns as Date, Time, Height, Period, and Direction. Click Finish. The Direction Angle Convention window will open. It may take a minute for the file to load. Click Ok twice.



[image: ]
Figure 9. Wave Events Set Up.

[image: ]
Figure 10. File Import Wizard for Wave Gauge Information.
2.8 Convert to GenCade Model Grid – Part 2
· Reconvert the map to 1D grid by right-clicking on default coverage and selecting Convert->Map to 1D Grid.

3.  Setup and Run GenCade Model
When GenCade Grid in the left panel is highlighted, the GenCade menu will appear. 
· Click on Edit Wave Data and Edit Groins to confirm that all data was transferred to the 1D grid.
· Go to Model Control. Under the Model Setup tab, define the Start Date as 01-Jan-1970 12:00 AM, the End Date as 31-Dec-1974 12:00 AM, the Time Step as 0.5 (hr), and the Recording Time Step as 168 (hr).

[image: ]
Figure 11. GenCade Model Control.

· Select the Beach Setup tab. Under Sand and Beach Data, change the Effective Grain Size to 0.2, the Average Berm Height to 1, and the Closure Depth to 10. The Longshore Sand Transport Calibration Coefficients, K1 and K2, should be 0.5 and 0.25, respectively.
· Under the Seaward BC and Lateral BC tab, use the default for all parameters.
· Go to File->Save As to save the project.
· Go to GenCade->Run GenCade to run the model.

4. Visualizing Results in the SMS
During a GenCade simulation, several output files are produced (*.slo, *.irv, *.qtr, *.prt, *.mqn, *.mqr, *.mql).
· *.slo – Shoreline Change file: The shoreline change file includes the shoreline position at each recording time step.
· *.irv – Inlet Shoal Volume file: Volumes for each component are output at each recording time step in this file.
· *.qtr – Longshore Transport file – The longshore transport file includes the calculated net transport at each recording time step.
· *.prt – Print file: The print file includes all of the information saved during the run including the shoreline position, shoreline change, breaking wave angle, offshore wave angle to the x-axis, and transport volume to the left and right after each year. The print file cannot be imported into the SMS.
· *.mqn, *.mqr, and *.mql – Mean annual net transport rate, mean annual transport rate to the right, and mean annual net transport rate to the left – These files include the mean transport for each year and the average of all years.
 The *.slo, *.irv, and *.qtr files can be viewed in the SMS. 
· To view the *.slo file (shoreline change), simply drag the file into the viewing window in the SMS.
· Three new datasets (Shoreline Change, Rate of Change, and Shoreline) are available under GenCade Grid.
· To update the time steps, right-click on Time steps and go to Time Settings. Change the Zero Time to 1/1/1970 12:00:00 AM and change the Time Display to Absolute Date/Time. The shoreline can be viewed at each recorded time step.

[image: ]
Figure 12. Visualization of Shoreline Change.

· To open a shoreline graph window, click Display->Plot Wizard, select GenCade Shoreline from the Plot Type list on the Step 1 window, select Active dataset and Active time step from the Step 2 window.

[image: ]
Figure 13. Visualization Using Plot Wizard.

5. Modifications to GenCade
GenCade can be modified in the conceptual model or the GenCade model. It is recommended to make changes in the conceptual during calibration or for alternatives, because changes in the conceptual model are saved. When many different alternatives are created, it can be confusing to remember which alternatives represent what scenarios when the only differences between alternatives occur in the GenCade model. This first example will show how to make modification in both the conceptual model and the GenCade model. Modifications will only be made in the GenCade model for the following cases.

· Reopen the *.sms file. To make changes in the conceptual model, delete the GenCade grid by right-clicking on the GenCade grid and scrolling to Delete.
· Select the Select Feature Arc button and double-click on the groin. The GenCade Arc Attributes window will open; click on Attributes. Change the Permeability to 0.6.
· Right-click on the default coverage and go to Convert->Map to 1D Grid. Notice that the permeability of the groin has changed from 0.3 to 0.6 under Edit Groins.
· It is necessary to redefine the model parameters before saving and running GenCade.
· Compare this case to the original by opening both *.slo files in the SMS.
· To modify the GenCade grid in the GenCade model, simply go to GenCade->Edit Groins and manually modify the permeability. All of the other parameters will not be altered.

A second sensitivity test is to change the wave direction. This can be done by going to Edit Wave Data, clicking Data, and replacing the existing waves by going to Import.

6. Modifying the Grid Spacing
The last sensitivity test requires modifying the grid spacing to take advantage of the variable grid resolution. Although this test is very simple and only requires a few minutes to complete the simulation, variable grid resolution can speed up slower simulations and help refine the spacing in necessary locations.
· Click on Create Feature Point and add a feature point just south of the groin. The location of this point should be (-10000, -500).
· Click on Select Feature Point and select the point. The Refine Point window will open. Check the Refine grid in I direction and change the Base cell size to 25. Click OK.
· Delete the existing GenCade grid. Then click on default coverage and select Convert->Map to 1D Grid. Click Use refine points under I Cell Options and change the Maximum cell size to 100 ft. Use the default for Maximum bias and uncheck User Inner Growth. Click OK. It is necessary to update the model parameters and save before running GenCade. 

[image: ]
Figure 14. Variable Grid Resolution.
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